matomoでGeo IPを有効にしたい


HOW DO I INSTALL THE PHP EXTENSION FOR GEOIP 2?

./bootstrap 実行時に autoreconfが無いとエラーがでるので、以下パッケージをインストール。

apt install dh-autoreconf

後は手順通りで問題なし。

と、思ったら、ubuntuのパッケージを用意してくれていた様子…

https://github.com/maxmind/libmaxminddb/blob/main/README.md#installing-from-a-tarball

On Ubuntu via PPA

MaxMind provides a PPA for recent version of Ubuntu. To add the PPA to your APT sources, run:

$ sudo add-apt-repository ppa:maxmind/ppa

Then install the packages by running:

$ sudo apt update
$ sudo apt install libmaxminddb0 libmaxminddb-dev mmdb-bin